Effect problem

In this forum you will find and post information regarding the modding of Star Wars Battlefront 2. DO NOT POST MOD IDEAS/REQUESTS.

Moderator: Moderators

Chief Warrant Officer
User avatar
Posts: 336
Joined: Wed Feb 17, 2016 8:51 am
Location: France
Projects :: Battlefront Ultimate Commander
Games I'm Playing :: swbf I + II
xbox live or psn: No gamertag set

Effect problem

Postby CdtFox » Fri Mar 31, 2017 6:23 am

Hello GT,

I have a couple of issue with my effects explosion for grenade and launchers. In the odf when i change the .fx by my new one it works, but it use the new effect only one time every three grenade explosion, the two other time are using the stock effect.

Here is my odf:
Hidden/Spoiler:
Code: Select all
[ExplosionClass]
ClassParent       = "com_weap_inf_thermaldetonator_exp"

[Properties]

Effect              = "rep_sfx_weap_thermaldetonator_exp"


And here is the class parent, "com_weap_inf_thermaldetonator_exp":

Hidden/Spoiler:
Code: Select all
[ExplosionClass]
ClassLabel          = "explosion"

[Properties]
Damage              = "450.0"
DamageRadiusInner   = "4.5"
DamageRadiusOuter   = "6.5"

Push                = "10.0"
PushRadiusInner     = "6.5"
PushRadiusOuter     = "6.5"

Shake               = "0.5"
ShakeLength         = "0.75"
ShakeRadiusInner    = "8.0"
ShakeRadiusOuter    = "15.0"

Effect              = "rep_sfx_weap_thermaldetonator_exp"
WaterEffect         = "com_sfx_watersplash_lg"
Decal               = "decal_explosion"
LightColor          = "255 220 100 255"
LightRadius         = "7.0"
LightDuration       = "1.0"

VehicleScale        = "1.0"
PersonScale         = "1.0"
DroidScale          = "1.0"
BuildingScale       = "1.0"
AnimalScale         = "1.0"

SoundProperty       = "com_weap_thermaldetonator_exp"
//WaterExplosion       = "com_weap_obj_med_water_exp"


Also when i use the stock "com_weap_inf_thermaldetonator_exp" without modifications it ignores completly the new effect, even if this is wroted in my side .odf.

Sith Master
User avatar
Posts: 2556
Joined: Mon Aug 04, 2008 10:32 am
Location: Pizza Land
Projects :: TOR GCWII GCW1035
xbox live or psn: Johnny_Sciroppo

Re: Effect problem

Postby Delta-1035 » Fri Mar 31, 2017 8:16 am

I had the same issue a few days ago, it seems that ClassParent with explosions does not work well enough to change the effect.

The simple fix is to make a fully working rep_..._exp.odf with your new effect and ignore the com_...._exp_odf.

Return to SWBF2 Modding

Who is online

Users browsing this forum: thingshappen77 and 4 guests