Rends adding Sound Tutorial

In this forum you will find and post information regarding the modding of Star Wars Battlefront 2. DO NOT POST MOD IDEAS/REQUESTS.

Moderator: Moderators

Recruit Womprat Killer
User avatar
Posts: 8
Joined: Wed Sep 14, 2016 1:24 pm
Projects :: No Mod project currently.
Games I'm Playing :: SWBF2
xbox live or psn: PSN: Atephious

Re: Rends adding Sound Tutorial

Postby Atephious » Tue Sep 20, 2016 7:17 pm

I am having a bit of difficulty. the sounds wont run even after following this tutorial to the T. I even started from scratch and tried it with the updated mung files. sound only didnt work at first so I redid it again with the edited munge stings found in this tutorial. the sound only worked but the sound .lvl is only 8 bytes and only contains null. Its a bit frustrating.

Recruit Womprat Killer
Posts: 9
Joined: Wed Apr 12, 2017 5:57 pm
Projects :: No Mod project currently.
Games I'm Playing :: SWBF 2
xbox live or psn: No gamertag set

Re: Rends adding Sound Tutorial

Postby Wolffe1138 » Sun Apr 16, 2017 9:07 pm

I have followed step by step and even did the extra steps just incase and I still don't have a sound folder in my addon folder, any suggestions?

EDIT: Nvm It fixed it

Recruit Womprat Killer
Posts: 12
Joined: Sat Jun 24, 2017 12:27 am
Projects :: No Mod project currently.
Games I'm Playing :: SWBF2
xbox live or psn: No gamertag set

Re: Rends adding Sound Tutorial

Postby GAMEDOGSHIPMENT » Thu Jul 13, 2017 7:02 am

What I learned from fixing issues about this tutorial.

1. Is the tutorial working ?
Yes it should work if EXACTLY step by step ,(more on later)

2. Where to find sound.sfx lines
Search your maps data/sound folder and choose the map folder that has the stock vehicle already been used on some other map. Choose the appropriate era .sfx file and look for tags that have your vehicle name

3. Did the step by step? Still does not load file but loads the vehicle ?

Loading the vehicle is the more easy part sounds are tricky due to the munging problems.

1. Set up all your vehicle spawns and paths and test munge all before adding sounds u can skip this but just incase so be sure its only the sound problem.

2. When editting your scripts file for conquest or whatever mode you made, make sure when you type....
Code: Select all
ReadDataFile("dc:sound\\tes.lvl;tescw")


Is actually the name for your map too, i noticed that naming this folder and .lvl anything else but your map names causes the munger to skip it from creating a .lvl file so better to name it same file and place all the sound .sfx code lines there.

Here is an example, lets say your world is called AAA

when typing ReadDataFile.... it must be named ....
Code: Select all
ReadDataFile("dc:sound\\AAA.lvl;AAAcw")


Now when you go your data_AAA/Sound/Worlds/ folder you will see a folder named test

Copy that (just like in tut) paste it same place, it will say test - copy, rename that to you MAP NAME, so name it AAA or whatever the name of your map is.

And the .sfx file and .req files should all be renamed to AAA, so AAA.req, AAAcw.req, and AAAcw.sfx

In your req file delete extra tid bit, so your req MUST LOOK LIKE THIS AS A BASE PLATE AND THEN ADD EXTRA PLS DELETE THE CODE THAT WAS ALREADY BEEN THERE
Code: Select all
ucft
{
   REQN
   {
      "str"
      "align=2048"
      

   }
   REQN
   {
      "lvl"
      "AAAcw"
   }   
 }


Now for your AAAcw.req, SAME THING IT MUST BE A BASE PLATE LIKE SO.....
Code: Select all
ucft
{
   REQN
   {
      "bnk"
      "align=2048"
      "AAAcw"
   }

   REQN
   {
      "config"
      "imp_walk_atst"--add more walkers or whatever ships you have if u want more vehicles
   }
 }


There all done

NOW IMPORTANT

FIRST DO A MUNGE ALL

SO GO TO YOUR MUNGE PROGRAM

TICK SELECT ALL

AND WAIT FOR MUNGE

THEN DO ANOTHER MUNGE BUT THIS TIME....

TICK UNSELECT ALL

AND TICK SOUND ONLY

WAIT FOR MUNGE AND THE ISSUES SHOULD BE CLEARED OUT

Previous

Return to SWBF2 Modding

Who is online

Users browsing this forum: No registered users and 6 guests