vehicle help in xsi bad model type #model [Solved]

How to create models in XSI and other 3D applications and make them work in Battlefront 1 & 2. Post models, tips for application usage and share anything XSI, 3DMax, SketchUp, etc.

Moderator: Moderators

Private Recruit
User avatar
Posts: 18
Joined: Mon May 11, 2015 12:36 am
Projects :: No Mod project currently.
xbox live or psn: No gamertag set

vehicle help in xsi bad model type #model [Solved]

Postby savinpvtmike » Thu May 11, 2017 2:42 pm

so im working on a new tie fighter but i keep getting an error (bad model type #model) in the dummyroot, how can i find it and fix it?
i know the supported model types are poly mesh, null, and bone but idk how to fix that.
Last edited by savinpvtmike on Sun May 14, 2017 9:16 pm, edited 1 time in total.

Modeling Master
Posts: 673
Joined: Fri Mar 31, 2006 11:02 pm
Location: alberta, canada
Projects :: Scarif Map Pack and Starter Kit

Re: vehicle help in xsi bad model type #model

Postby Gogie » Thu May 11, 2017 2:56 pm

First send a screenshot of your heirarchy in explorer mode (press 8 in XSI)

I've encountered this problem a few times myself...

Most of the time when i've seen this it was caused by some sort of improper import i'll give a brief example of what im talking about.

At one point while I was working on my player meshes for Scarif, I had encountered this error, the cause was an object (it was a cyllinder) that kept telling me bad model type... Well what the heck how can a cyllinder be a bad model type right? Well... in all reality this cyllinder when I tried to find it, although it existed in the explorer (was named something like cyllinder#) on the view port it didn't have any model components... it simply did not exist, after deleting that imaginary cyllinder my scene exported perfectly...

I'm not sure what is causing this error for you but make sure all of your models in the explorer actually have a mesh component.

Also if you could post what the bad model type is or the exact error report it may be of more help.

Of final note: if you are using XSIZETOOLS I recommend posting on the XSIZETOOLS sticky posted on the 3D Modelling & Animation forum, the creator ANDEWEGET seems very very kind in helping and answering questions with this tool.

Private Recruit
User avatar
Posts: 18
Joined: Mon May 11, 2015 12:36 am
Projects :: No Mod project currently.
xbox live or psn: No gamertag set

Re: vehicle help in xsi bad model type #model

Postby savinpvtmike » Thu May 11, 2017 4:01 pm

great now zero editor wont start stupid runtime error again arrgggg

Recruit Womprat Killer
User avatar
Posts: 9
Joined: Sat Apr 22, 2017 4:58 am
Location: United States
Projects :: SWBFII- ARC ACTS- CTF CTG TMK PPD TFK
Games I'm Playing :: SWBFII ACTS WTFZF ++
xbox live or psn: N/A

Re: vehicle help in xsi bad model type #model

Postby Psyringe » Thu May 11, 2017 4:31 pm

Most of the time I encounter this error it's due to having the wrong object selected before export; or as Gogie suggested an artifact of some kind. I've also encountered errors when I have many XSI windows open; sometimes it helps to only have the necessities when exporting (Explorer/ZETools).

**edit**

An easy reference for this error is HOTH_bldg_bunker, while exporting a non-triangulated revision. Cylinder issues. Could have something to do with the Non-Triangulated import or maybe Non-Optimized points. Other Pandemic games require triangulation before export; ZE Tool handles it here. :D

Private Recruit
User avatar
Posts: 18
Joined: Mon May 11, 2015 12:36 am
Projects :: No Mod project currently.
xbox live or psn: No gamertag set

Re: vehicle help in xsi bad model type #model

Postby savinpvtmike » Thu May 11, 2017 8:52 pm

ok befor i go any further cus i think i got it to export i see it in a mesh veiwer but is there a good tutorial to exporting a vehicle from xsi animated and every thing and then setting it up in zero editor to fly it in a map?
i was watching these tuts https://www.youtube.com/watch?v=OJNy60eMG8w to set it up but he never made tuts to porting it in game and i cant find docs for it so ya.

Return to 3D Modeling & Animation

Who is online

Users browsing this forum: No registered users and 2 guests