Problem with turret [Solved]

How to create models in XSI and other 3D applications and make them work in Battlefront 1 & 2. Post models, tips for application usage and share anything XSI, 3DMax, SketchUp, etc.

Moderator: Moderators

Private Recruit
User avatar
Posts: 29
Joined: Sun May 07, 2017 11:31 pm
Location: Kentucky, USA
Projects :: Resistance VS First Order side mod
Games I'm Playing :: All teh BFs

Problem with turret [Solved]

Postby Calrissian97 » Fri Jan 19, 2018 5:34 pm

So I'm making a turret outside a capital ship and for some reason when I'm aiming directly ahead it's sticking almost straight up?
Screenie:
Hidden/Spoiler:
Image

Fragme's Tutorial is too vague without the images, and there aren't any other detailed tutorials on modeling turrets.
Here is how it looks in XSI:
Hidden/Spoiler:
Image

The hierarchy:
Hidden/Spoiler:
Image


And then here's the odf:
Hidden/Spoiler:
Code: Select all
[GameObjectClass]
ClassLabel              = "armedbuilding"
GeometryName            = "for_ship_left_turret.msh"

[Properties]

Pilottype               = "remote"
BUILDINGSECTION         = "BODY"

MapTexture              = "turret_icon"
IconTexture             = "HUD_all_lascannon_icon"

MapScale                = "0.0"
HealthTexture           = "HUD_kam_turret_icon"

GeometryName            = "for_ship_left_turret"
ExplosionName           = "all_bldg_moncal_roundturret_exp"
DestroyedGeometryName   = "all_bldg_moncal_roundturret_chunk1"

MaxHealth               = "2500.0"
RespawnTime            = "120"

BUILDINGSECTION         = "TURRET1"

Pilottype               = "remote"

TurretNodeName          = "turret_body"

PitchLimits             = "-180 180"
YawLimits               = "-5 90"

TrackCenter   = "3.0 -54.0 343.0" //x y z

PitchTurnFactor         = "0.0"

//FirstPerson           = "com\comviewf;com_1st_cockpit_viewfinder"
ThirdPersonFOV          = "65"
WeaponName              = "all_weap_moncal_roundturret"
WeaponAmmo              = "0"

MaxTurnSpeed            = "90.8"
MaxPitchSpeed           = "90.8"
PitchRate               = "90.0"
TurnRate                = "90.5"
PCMaxPitchSpeed         = "90.0"
PCMaxTurnSpeed          = "90.0"   


TURRETSECTION           = "TURRET1"

AimerNodeName           = "hp_aimer"
AimerPitchLimits         = "-5 75"
AimerYawLimits           = "-5 75"

BarrelNodeName          = "barrel_body"
BarrelRecoil            = "0.5"
FirePointName           = "hp_fire"

//Sound
TurretYawSound         = "turret_whir_yaw_lp"
TurretYawSoundPitch    = "0.7"
TurretPitchSound       = "turret_whir_pitch_lp"
TurretPitchSoundPitch  = "0.7"
TurretAmbientSound     = ""
TurretActivateSound    = "vehicle_equip"
TurretDeactivateSound  = "vehicle_equip"
TurretStartSound       = ""
TurretStopSound        = ""

FoleyFXGroup           = "metal_foley"


Any help would be greatly appreciated. :runaway:
Last edited by Calrissian97 on Fri Jan 19, 2018 11:30 pm, edited 2 times in total.

Gametoast Staff
Posts: 3460
Joined: Mon Aug 21, 2006 6:23 am

Re: Problem with turret

Postby AceMastermind » Fri Jan 19, 2018 7:09 pm

Calrissian97 wrote:Fragme's Tutorial is too vague without the images, and there aren't any other detailed tutorials on modeling turrets.

Not really needed since you can now import any of the shipped examples directly into XSI with ZETools and inspect or play around with them.
Your hierarchy looks ok, but I think your yaw and pitch values should be swapped.

Refer to this for setting up your turret ODF values:
viewtopic.php?p=459956#p459956

Private Recruit
User avatar
Posts: 29
Joined: Sun May 07, 2017 11:31 pm
Location: Kentucky, USA
Projects :: Resistance VS First Order side mod
Games I'm Playing :: All teh BFs

Re: Problem with turret

Postby Calrissian97 » Fri Jan 19, 2018 11:29 pm

Thanks Ace! I couldn't fix it, so I just used aimers only like described in the tut by Darth Duck. Works great! A shame I couldn't figure out what was wrong with the turret node, but I'm going to call it solved.

Return to 3D Modeling & Animation

Who is online

Users browsing this forum: No registered users and 1 guest