Custom Capital Ship Collision

How to create models in XSI and other 3D applications and make them work in Battlefront 1 & 2. Post models, tips for application usage and share anything XSI, 3DMax, SketchUp, etc.

Moderator: Moderators

Private First Class
User avatar
Posts: 81
Joined: Sun May 07, 2017 11:31 pm
Location: Kentucky, USA
Projects :: A New Frontier Era Mod
Games I'm Playing :: All teh BFs

Custom Capital Ship Collision

Postby Calrissian97 » Mon Feb 26, 2018 11:29 pm

I've got quite the conundrum for you, GT. So I've already got my custom capital ship divided in about 7 different parts. It all fits together using normal collisions and everything is dandy. Until I edit a single part so that I can fit a larger, custom hangar in it. Ever since, the piece I edited has been "pushed back" by the other pieces for lack of better words. I've removed every internal msh so it's just the capital ship parts. Every part has -nocollision listed in their respective msh.option files. I've placed collision primitives tagged with -svo to act as the collision in the interim. When placed alone, the msh doesn't move. Only when placed in its position on the capital ship does it move. This "move" only occurs in-game. In ZE it looks just how I placed it.
Here are some screenshots showing the aforementioned part, while rendering the collision prims of any part near it with freecam.

A. (The piece)
Hidden/Spoiler:
Image

Note: You can see where it's pushed back by the square gap in front of the hangar.

B. (Piece to the right)
Hidden/Spoiler:
Image


C. (Piece to the left)
Hidden/Spoiler:
Image


D. (Piece in front)
Hidden/Spoiler:
Image


E. (Piece below/behind)
Hidden/Spoiler:
Image


And here's what it looks like in ZE:
Hidden/Spoiler:
Image


I've spent over a week on this, trying to get this one mesh to cooperate. Any help would be greatly appreciated, as I'm running out of options. :runaway:

Return to 3D Modeling & Animation

Who is online

Users browsing this forum: No registered users and 2 guests