Animations not working...

How to create models in XSI and other 3D applications and make them work in Battlefront 1 & 2. Post models, tips for application usage and share anything XSI, 3DMax, SketchUp, etc.

Moderator: Moderators

Private Third Class
User avatar
Posts: 46
Joined: Fri Aug 04, 2017 1:46 pm
Projects :: Kessel - Prison
xbox live or psn: No gamertag set

Animations not working...

Postby Dasher » Mon Mar 26, 2018 1:57 am

Hey,

I've been having problems getting simple door animations to work lately. I don't know what's wrong, I've followed the tutorial here on GT several times step by step, also I've created plenty of doors, but my animations don't seem to work. When I apply older animations to my mesh they work perfectly, so it can't be the model that's faulty. I have tried several ways of exporting the animation, I've followed the instructions in the ZETools guide and FragMe!'s step by step and as dilligently as I could, but the doors stay closed in-game. Is there anything I missed to do? I have the improved munge files and as I said in my last map the animations worked fine...any help would be appreciated :runaway:

Sith
User avatar
Posts: 1447
Joined: Thu Jan 23, 2014 6:01 am
Location: Right behind you :)
Projects :: Star Wars - Battlefront III Legacy
Games I'm Playing :: Swbf GTA CoD LoL KH
xbox live or psn: El_Fabricio#

Re: Animations not working...

Postby thelegend » Mon Mar 26, 2018 5:49 am

Maybe you could post a screenshot of your model hierarchi in XSI. I often had that issue and sometimes it's due to incorrect hierarchi structure.

Private Third Class
User avatar
Posts: 46
Joined: Fri Aug 04, 2017 1:46 pm
Projects :: Kessel - Prison
xbox live or psn: No gamertag set

Re: Animations not working...

Postby Dasher » Mon Mar 26, 2018 6:25 am

Hmm I figured that much. I've tried several hierarchies, inluding this one http://gametoast.com/viewtopic.php?f=36&t=31904&p=520880&hilit=door+animation#p520880

I even set up my hierarchy the way it was set up in my previous files which had working animations, still no success. The munge.bat files in my animation folder aren't responsible, since I munged the working open.msh and basepose.msh and got working animations.


I'll post a picture later, but for now this is the hierarchy that I've used on my other doors:

dummyroot
........- bone_root
....................-bone_doorl
....................-bone_doorr
....................-bone_dooru
....................-bone_doord

....................-doorl
....................-doorr
....................-dooru
....................-doord
........- hp_active

Return to 3D Modeling & Animation

Who is online

Users browsing this forum: No registered users and 1 guest